Yüksek CVSS 8.8 PoC var
CVE-2023-2017: Shopware: güvenlik açığı
Açıklama (NVD)
Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validation checks in `Shopware\Core\Framework\Adapter\Twig\SecurityExtension` and call any arbitrary PHP function and thus execute arbitrary code/commands via usage of fully-qualified names, supplied as array of strings, when referencing callables. Users are advised to upgrade to v6.4.20.1 to resolve this issue. This is a bypass of CVE-2023-22731.
Özet bilgiler
- Ürün
- Shopware Shopware
- CVSS v3.1
- 8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - EPSS
- %2,07 (yüzdelik 81)
- CWE
- CWE-184
- Yama
- Geçici çözüm
Etkilenen sürümler
| Ürün | Başlangıç | Bitiş | Düzeltildi |
|---|---|---|---|
| shopware-shopware | 6.1.0 | 6.4.20.0 | — |
| shopware-shopware | 6.5.0.0 | 6.5.0.0 | — |
| shopware-shopware | 6.5.0.0 | 6.5.0.0 | — |
| shopware-shopware | 6.5.0.0 | 6.5.0.0 | — |