İçeriğe geç
Bilgi ve Teknoloji Uygulamada aç

Yüksek CVSS 8.8

CVE-2024-39877: Airflow: kod enjeksiyonu

Yayın: · Güncelleme:

Açıklama (NVD)

Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.

Özet bilgiler

Ürün
Apache Airflow
CVSS v3.1
8.8 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
%1,73 (yüzdelik 78)
CWE
CWE-94
Yama
Mevcut

Etkilenen sürümler

ÜrünBaşlangıçBitişDüzeltildi
apache-airflow2.4.0—2.9.3

Kaynaklar

Uygulamada aç Tüm CVE kayıtları