Kritik CVSS 9.8
CVE-2024-45409: Ruby-saml: güvenlik açığı
Açıklama (NVD)
The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.
Özet bilgiler
- Ürün
- Onelogin Ruby-saml
- CVSS v3.1
- 9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - EPSS
- %10,68 (yüzdelik 96)
- CWE
- CWE-347
- Yama
- Mevcut
Etkilenen sürümler
| Ürün | Başlangıç | Bitiş | Düzeltildi |
|---|---|---|---|
| onelogin-ruby-saml | — | — | 1.12.3 |
| onelogin-ruby-saml | 1.13.0 | — | 1.17.0 |
| omniauth-omniauth-saml | — | 1.10.3 | — |
| omniauth-omniauth-saml | 2.0.0 | 2.0.0 | — |
| omniauth-omniauth-saml | 2.1.0 | 2.1.0 | — |
| gitlab-gitlab | — | — | 16.11.10 |
| gitlab-gitlab | 17.0.0 | — | 17.0.8 |
| gitlab-gitlab | 17.1.0 | — | 17.1.8 |
| gitlab-gitlab | 17.2.0 | — | 17.2.7 |
| gitlab-gitlab | 17.3.0 | — | 17.3.3 |