Orta CVSS 6.1
CVE-2025-21621: Geoserver: siteler arası betik çalıştırma (XSS)
Açıklama (NVD)
GeoServer is an open source server that allows users to share and edit geospatial data. Prior to version 2.25.0, a reflected cross-site scripting (XSS) vulnerability exists in the WMS GetFeatureInfo HTML output format that enables a remote attacker to execute arbitrary JavaScript code in a victim's browser through specially crafted SLD_BODY parameters. This issue has been patched in version 2.25.0.
Özet bilgiler
- Ürün
- Geoserver Geoserver
- CVSS v3.1
- 6.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - EPSS
- %0,32 (yüzdelik 25)
- CWE
- CWE-79
- Yama
- Mevcut
Etkilenen sürümler
| Ürün | Başlangıç | Bitiş | Düzeltildi |
|---|---|---|---|
| geoserver-geoserver | — | — | 2.25.0 |