İçeriğe geç
Bilgi ve Teknoloji Uygulamada aç

Kritik CVSS 9.6

CVE-2025-55754: Tomcat: güvenlik açığı

Yayın: · Güncelleme:

Açıklama (NVD)

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.

Özet bilgiler

Ürün
Apache Tomcat
CVSS v3.1
9.6 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
%10,34 (yüzdelik 96)
CWE
CWE-150
Yama
Yok / bilinmiyor

Etkilenen sürümler

ÜrünBaşlangıçBitişDüzeltildi
apache-tomcat8.5.608.5.100—
apache-tomcat9.0.40—9.0.109
apache-tomcat10.0.0—10.0.27
apache-tomcat10.1.0—10.1.45
apache-tomcat11.0.0—11.0.11

Kaynaklar

Uygulamada aç Tüm CVE kayıtları