Yüksek CVSS 8.2
CVE-2025-57822: Next.js: sunucu taraflı istek sahteciliği (SSRF)
Açıklama (NVD)
Next.js is a React framework for building full-stack web applications. Prior to versions 14.2.32 and 15.4.7, when next() was used without explicitly passing the request object, it could lead to SSRF in self-hosted applications that incorrectly forwarded user-supplied headers. This vulnerability has been fixed in Next.js versions 14.2.32 and 15.4.7. All users implementing custom middleware logic in self-hosted environments are strongly encouraged to upgrade and verify correct usage of the next() function.
Özet bilgiler
- Ürün
- Vercel Next.js
- CVSS v3.1
- 8.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - EPSS
- %2,58 (yüzdelik 85)
- CWE
- CWE-918
- Yama
- Mevcut
Etkilenen sürümler
| Ürün | Başlangıç | Bitiş | Düzeltildi |
|---|---|---|---|
| vercel-next.js | — | — | 14.2.32 |
| vercel-next.js | 15.0.0 | — | 15.4.7 |