Yüksek CVSS 8.8
CVE-2025-62164: Vllm: hatalı girdi doğrulama
Açıklama (NVD)
vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.
Özet bilgiler
- Ürün
- Vllm Vllm
- CVSS v3.1
- 8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - EPSS
- %0,96 (yüzdelik 62)
- CWE
- CWE-20
- Yama
- Mevcut
Etkilenen sürümler
| Ürün | Başlangıç | Bitiş | Düzeltildi |
|---|---|---|---|
| vllm-vllm | 0.10.2 | — | 0.11.1 |
| vllm-vllm | 0.11.1 | 0.11.1 | — |
| vllm-vllm | 0.11.1 | 0.11.1 | — |