Yüksek CVSS 7.8 PoC var
CVE-2025-69262: Pnpm: işletim sistemi komut enjeksiyonu
Açıklama (NVD)
pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.
Özet bilgiler
- Ürün
- Pnpm Pnpm
- CVSS v3.1
- 7.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - EPSS
- %1,04 (yüzdelik 64)
- CWE
- CWE-78
- Yama
- Yok / bilinmiyor
Etkilenen sürümler
| Ürün | Başlangıç | Bitiş | Düzeltildi |
|---|---|---|---|
| pnpm-pnpm | 6.25.0 | — | 10.27.0 |