İçeriğe geç
Bilgi ve Teknoloji Uygulamada aç

Orta CVSS 6.5

CVE-2026-104713: Struts: güvenlik açığı

Yayın: · Güncelleme:

Açıklama (NVD)

Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin. A request body is read into memory without any bound on how much will be accepted, so a single request can cause the server to allocate memory in proportion to its size, exhausting the Java heap and denying service to other users. No additional setting has to be enabled. Applications that do not use the REST plugin are not affected. This issue affects Apache Struts: from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0. Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.

Özet bilgiler

Ürün
Apache Struts
CVSS v3.1
6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
%0,56 (yüzdelik 47)
CWE
CWE-770
Yama
Yok / bilinmiyor

Etkilenen sürümler

ÜrünBaşlangıçBitişDüzeltildi
apache-struts2.1.82.3.37—
apache-struts2.5.02.5.33—
apache-struts6.0.0—6.12.0
apache-struts7.0.0—7.4.0

Kaynaklar

Uygulamada aç Tüm CVE kayıtları