İçeriğe geç
Bilgi ve Teknoloji Uygulamada aç

Kritik CVSS 9.8

CVE-2026-27820: Zlib: arabellek taşması

Yayın: · Güncelleme:

Açıklama (NVD)

zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.

Özet bilgiler

Ürün
Ruby-lang Zlib
CVSS v3.1
9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS v4.0
1.7 CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
EPSS
%0,56 (yüzdelik 47)
CWE
CWE-120
Yama
Yok / bilinmiyor

Etkilenen sürümler

ÜrünBaşlangıçBitişDüzeltildi
ruby-lang-zlib——3.0.1
ruby-lang-zlib3.1.0—3.1.2
ruby-lang-zlib3.2.0—3.2.3

Kaynaklar

Uygulamada aç Tüm CVE kayıtları