İçeriğe geç
Bilgi ve Teknoloji Uygulamada aç

Orta CVSS 5.3

CVE-2026-33558: Kafka: güvenlik açığı

Yayın: · Güncelleme:

Açıklama (NVD)

Information exposure vulnerability has been identified in Apache Kafka. The NetworkClient component will output entire requests and responses information in the DEBUG log level in the logs. By default, the log level is set to INFO level. If the DEBUG level is enabled, the sensitive information will be exposed via the requests and responses output log. The entire lists of impacted requests and responses are: * AlterConfigsRequest * AlterUserScramCredentialsRequest * ExpireDelegationTokenRequest * IncrementalAlterConfigsRequest * RenewDelegationTokenRequest * SaslAuthenticateRequest * createDelegationTokenResponse * describeDelegationTokenResponse * SaslAuthenticateResponse This issue affects Apache Kafka: from any version supported the listed API above through v3.9.1, v4.0.0. We advise the Kafka users to upgrade to v3.9.2, v4.0.1, or later to avoid this vulnerability.

Özet bilgiler

Ürün
Apache Kafka
CVSS v3.1
5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
%0,63 (yüzdelik 50)
CWE
CWE-533
Yama
Geçici çözüm

Etkilenen sürümler

ÜrünBaşlangıçBitişDüzeltildi
apache-kafka0.11.0.0—3.9.2
apache-kafka4.0.04.0.0—
apache-kafka4.0.04.0.0—
apache-kafka4.0.04.0.0—
apache-kafka4.0.04.0.0—

Kaynaklar

Uygulamada aç Tüm CVE kayıtları