Yüksek CVSS 7.5 PoC var
CVE-2026-40863: Phpspreadsheet: güvenlik açığı
Açıklama (NVD)
PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0, the SpreadsheetML XML reader (Reader\Xml) does not validate the ss:Index row attribute against the maximum allowed row count (AddressRange::MAX_ROW = 1,048,576). An attacker can craft a SpreadsheetML XML file with ss:Index="999999999" on a <Row> element, which inflates the internal cachedHighestRow to ~1 billion. Any subsequent call to getRowIterator() without an explicit end row will attempt to iterate ~1 billion rows, causing CPU exhaustion and denial of service. This vulnerability is fixed in 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0.
Özet bilgiler
- Ürün
- Phpoffice Phpspreadsheet
- CVSS v3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - EPSS
- %0,40 (yüzdelik 34)
- CWE
- CWE-770
- Yama
- Geçici çözüm
Etkilenen sürümler
| Ürün | Başlangıç | Bitiş | Düzeltildi |
|---|---|---|---|
| phpoffice-phpspreadsheet | — | — | 1.30.4 |
| phpoffice-phpspreadsheet | 2.0.0 | — | 2.1.16 |
| phpoffice-phpspreadsheet | 2.2.0 | — | 2.4.5 |
| phpoffice-phpspreadsheet | 3.3.0 | — | 3.10.5 |
| phpoffice-phpspreadsheet | 4.0.0 | — | 5.7.0 |