Yüksek CVSS 7.5 PoC var
CVE-2026-42189: Russh: güvenlik açığı
Açıklama (NVD)
Russh is a Rust SSH client & server library. Prior to version 0.60.1, a pre-authentication denial-of-service vulnerability exists in the server's keyboard-interactive authentication handler. A malicious client can crash any russh-based server that implements keyboard-interactive auth (e.g., for 2FA/TOTP) with a single malformed packet, requiring no credentials. This issue has been patched in version 0.60.1.
Özet bilgiler
- Ürün
- Russh Project Russh
- CVSS v3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - EPSS
- %0,48 (yüzdelik 42)
- CWE
- CWE-770
- Yama
- Mevcut
Etkilenen sürümler
| Ürün | Başlangıç | Bitiş | Düzeltildi |
|---|---|---|---|
| russh-project-russh | — | — | 0.60.1 |
| warpgate-project-warpgate | — | — | 0.23.1 |