Kritik CVSS 9.8 CISA KEV
CVE-2026-42208: LiteLLM'de SQL Enjeksiyonu Açığı (CVE-2026-42208)
LiteLLM'in API anahtar kontrolünde veri karışıklığı var. Saldırgan veritabanından bilgi okuyabilir ve değiştirebilir. Hemen 1.83.7 veya üzeri sürüme güncelleyin.
Türkçe özet yapay zekâ ile üretildi.
Açıklama (NVD)
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.
Özet bilgiler
- Ürün
- Litellm Litellm
- CVSS v3.1
- 9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS v4.0
- 9.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - EPSS
- %89,42 (yüzdelik 100)
- CWE
- CWE-89
- Yama
- Mevcut
- KEV
- Eklenme: 2026-05-08 · Son tarih: 2026-05-11
Gerekli aksiyon: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Etkilenen sürümler
| Ürün | Başlangıç | Bitiş | Düzeltildi |
|---|---|---|---|
| litellm-litellm | 1.81.16 | — | 1.83.7 |