Yüksek CVSS 7.5
CVE-2026-42334: Mongoose: güvenlik açığı
Açıklama (NVD)
Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.9, 7.8.9, 8.22.1, and 9.1.6, a vulnerability allows bypassing Mongoose’s sanitizeFilter query sanitization mechanism via the $nor operator. When sanitizeFilter is enabled, Mongoose wraps query operators in $eq to neutralize them. However, prior to the fix, $nor was not included in the set of logical operators that are recursively sanitized. Because $nor accepts an array (like $and and $or), and arrays do not trigger hasDollarKeys(), malicious operators such as $ne, $gt, or $regex could be injected inside a $nor clause without being sanitized. This vulnerability is fixed in 6.13.9, 7.8.9, 8.22.1, and 9.1.6.
Özet bilgiler
- Ürün
- Mongoosejs Mongoose
- CVSS v3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - EPSS
- %0,27 (yüzdelik 20)
- CWE
- CWE-74
- Yama
- Geçici çözüm
Etkilenen sürümler
| Ürün | Başlangıç | Bitiş | Düzeltildi |
|---|---|---|---|
| mongoosejs-mongoose | — | — | 6.13.9 |
| mongoosejs-mongoose | 7.0.0 | — | 7.8.9 |
| mongoosejs-mongoose | 8.0.0 | — | 8.22.1 |
| mongoosejs-mongoose | 9.0.0 | — | 9.1.6 |