İçeriğe geç
Bilgi ve Teknoloji Uygulamada aç

Yüksek CVSS 8.8 PoC var

CVE-2026-42843: Grav-plugin-api: hatalı yetkilendirme

Yayın: · Güncelleme:

Açıklama (NVD)

Grav API Plugin is a RESTful API for Grav CMS that provides full headless access to your site's content, media, configuration, users, and system management. Prior to 1.0.0-beta.15, an insecure direct object reference and logic flaw in the Grav API plugin (UsersController::update) allows any authenticated user with basic API access (api.access) to modify their own permission configuration. An attacker can exploit this to escalate their privileges to Super Administrator (admin.super and api.super), leading to full system compromise and potential RCE. This vulnerability is fixed in 1.0.0-beta.15.

Özet bilgiler

Ürün
Getgrav Grav-plugin-api
CVSS v3.1
8.8 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
%0,35 (yüzdelik 29)
CWE
CWE-863
Yama
Yok / bilinmiyor

Etkilenen sürümler

ÜrünBaşlangıçBitişDüzeltildi
getgrav-grav-plugin-api1.0.01.0.0—
getgrav-grav-plugin-api1.0.01.0.0—
getgrav-grav-plugin-api1.0.01.0.0—
getgrav-grav-plugin-api1.0.01.0.0—
getgrav-grav-plugin-api1.0.01.0.0—
getgrav-grav-plugin-api1.0.01.0.0—
getgrav-grav-plugin-api1.0.01.0.0—
getgrav-grav-plugin-api1.0.01.0.0—
getgrav-grav-plugin-api1.0.01.0.0—
getgrav-grav-plugin-api1.0.01.0.0—
getgrav-grav-plugin-api1.0.01.0.0—
getgrav-grav-plugin-api1.0.01.0.0—
getgrav-grav-plugin-api1.0.01.0.0—
getgrav-grav-plugin-api1.0.01.0.0—

Kaynaklar

Uygulamada aç Tüm CVE kayıtları