Orta CVSS 6.1
CVE-2026-44580: Next.js: siteler arası betik çalıştırma (XSS)
Açıklama (NVD)
Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.
Özet bilgiler
- Ürün
- Vercel Next.js
- CVSS v3.1
- 6.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - EPSS
- %0,21 (yüzdelik 11)
- CWE
- CWE-79
- Yama
- Geçici çözüm
Etkilenen sürümler
| Ürün | Başlangıç | Bitiş | Düzeltildi |
|---|---|---|---|
| vercel-next.js | 13.0.0 | — | 15.5.16 |
| vercel-next.js | 16.0.0 | — | 16.2.5 |