İçeriğe geç
Bilgi ve Teknoloji Uygulamada aç

Orta CVSS 5.5 PoC var

CVE-2026-47770: Jq: güvenlik açığı

Yayın: · Güncelleme:

Açıklama (NVD)

jq is a command-line JSON processor. Prior to 1.8.2, comparing two sufficiently deeply nested arrays with the == operator exhausts the C stack on jq's ordinary command-line surface, resulting in denial of service via stack exhaustion (uncontrolled recursion). The crash occurs in jq's recursive structural comparison code, with the recursion repeating through jvp_array_equal() and jv_equal() in src/jv.c when comparing deeply nested arrays; a nearby sort comparator path through jv_cmp() in src/jv_aux.c overflows the stack at a larger nesting depth from the same missing recursion guard. Anyone running jq comparisons on attacker-controlled deeply nested JSON values, or embedding jq in a context where untrusted data can reach the == comparison path, is affected. This vulnerability is fixed in 1.8.2.

Özet bilgiler

Ürün
Jqlang Jq
CVSS v3.1
5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS v4.0
6.8 CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
EPSS
%0,15 (yüzdelik 4)
CWE
CWE-674
Yama
Geçici çözüm

Etkilenen sürümler

ÜrünBaşlangıçBitişDüzeltildi
jqlang-jq——1.8.2

Kaynaklar

Uygulamada aç Tüm CVE kayıtları