Yüksek CVSS 7.2 PoC var
CVE-2026-5627: Anythingllm: güvenlik açığı
Açıklama (NVD)
A path traversal vulnerability exists in mintplex-labs/anything-llm versions up to and including 1.9.1, within the `AgentFlows` component. The vulnerability arises from improper handling of user input in the `loadFlow` and `deleteFlow` methods in `server/utils/agentFlows/index.js`. Specifically, the combination of `path.join` and `normalizePath` allows attackers to bypass directory restrictions and access or delete arbitrary `.json` files on the server. This can lead to information disclosure, such as leaking sensitive configuration files containing API keys, or denial of service by deleting critical files like `package.json`. The issue is resolved in version 1.12.1.
Özet bilgiler
- Ürün
- Mintplexlabs Anythingllm
- CVSS v3.1
- 7.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - EPSS
- %0,82 (yüzdelik 58)
- CWE
- CWE-29
- Yama
- Mevcut
Etkilenen sürümler
| Ürün | Başlangıç | Bitiş | Düzeltildi |
|---|---|---|---|
| mintplexlabs-anythingllm | — | 1.9.1 | — |